2012 YZ450F EFI problems after rebuild...?


7 replies to this topic
  • MotoSarge

Posted January 18, 2013 - 07:20 AM

#1

So i just rebuild the top end on my bike and something is not right. Its like the bike is running really lean. I have the timing right.. I have no vacuum leaks on the intake boots, everything is straight. I checked it over and over. The first problem is that my start/idler knob does not work at all. I use to be able to pull it out to start, and once warmed up i push it in and i could click it clockwise or counterclockwise to make the rpm's go up and down, or richer/ leaner. After I got the bike all back together the knob does not work at all. I also noticed now the header pipe is getting really hot and glowing red. Does anyone know if this is because when I took the flywheel off it resets the efi computer? Do I need to take it to the dealer to have them program it again or what? Other than that the bike starts fine. Its acting like the EFI has lost its touch. Its feeling like a 2 stroke.. if I blip the throttle she sometimes dies, other times its like bbrrrrrrAAAAAAAP.. there is a really bad bog which there never was before. This bike use to be a really crisp throttle response and would breath fire.. now she is weak as hell. Anyone have this problem?

  • SparksXR426

Posted January 19, 2013 - 10:44 PM

#2

Is it possible that some debris managed to get into the fuel line between the tank and injector while it was apart and plugged the injector partially? (ive got dirty injectors on the brain lately)
Assuming of course, everything was assembled properly. No, your computer shouldnt need any kind of a "reboot", its not that sophisticated.
Im no real expert on these bikes, theres plenty of those roaming this forum, it just sounds like your not getting enough fuel and theres only a couple things that'll cause that.

  • jnabuurs

Posted January 20, 2013 - 07:38 AM

#3

Are you sure all connections like thrrottleposition sensor etc are clean and connected. The header pipe always becomes red that's no problem.
The timing is a little different at this bike and there are more timing points on the exhaust cam and the piston must not be in TDC. ( I think you know)

  • MotoSarge

Posted January 20, 2013 - 09:19 AM

#4

Yeah I did exactly what the book says for timing. The only thing I didnt put on between the fuel line connection and the fuel tank is there is an orange peice which is called sort sort of cover. I did not put that piece back on. I wonder if thats the problem, but I dont see it being that. I had the bike running great after the rebuild, then the timing slipped.. I fixed it, and after that it ran like crap.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • laudy152

Posted January 20, 2013 - 06:37 PM

#5

What do you mean timing slipped? Could you have bent a valve?

  • MotoSarge

Posted January 21, 2013 - 06:53 AM

#6

The intake cam would get off its mark on the timing. Like I would be riding or I would be at an idle.. and it would kinda clank.. and stop. Then after it would not start. I would take off the valve cover and the timing mark on the intake cam was off. But it has not done that anyone. It was my first 4 stroke rebuild and I believe it was from me not tightening the cam caps in the order the book says to.

  • laudy152

Posted January 21, 2013 - 07:50 AM

#7

I would advise compression and leak down tests to start off with

  • grayracer513

Posted January 21, 2013 - 08:30 AM

#8

I believe it was from me not tightening the cam caps in the order the book says to.


If that's the case, you will have probably damaged the cam cap. It's possible that if the cap was overtorqued or torqued out of sequence that it became distorted and need to be line bored or polished back straight again. Another possibility is that the cam chain one or more links that are stiff and binding, which causes the cam chain tensioner to malfunction and allow the chain to skip.





Related Content

Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
Forums
Photo

First Hare scramble tips by dhend8


Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
Forums
Photo

Michigan Motocross Tires by 288yz450


Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.